Firebird Nation banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hi im a new owner of a 91 firebird.when i bought the car i test drove it and it did have a terrible miss.g the dealer ship and finding out that 41 psi is right two weeks later it will barely run. i replaced the fuel pump my new pump is reading 41 psi...the same as my old one . so then i changed the pressure regulator. still running the same wont take gas at all ... i bought for new injectors but my mechanic told me to send them back cause he thought that it took more than 41 psi to run a tune port ....i know different now after researching. he was thinking that since we didnt by the name brand fuel pump from the dealer ship we should go that rout but after leaving the dealer ship i now know that im getting the right pressure ive read alot of forums this morning that has givin me alot of i deas has any one had this problem please help just wanna get out and play with my new toy.... :(
 

·
']['exXxas']['itan
Joined
·
759 Posts
Could be a multitude of issues. I would start by unplugging one spark plug wire at a time and listen for a noticable drop in RPM. If you pull a wire and it makes no difference, then suspect that cylinder causing the issue. Check them all this way. A bad injector, mass air flow(not sure if 91 has one or not), EGR valve, plug wire, spark plug, and many other things can cause the engine to run rough. First need to isolate which cylinders are the culprits. If they all drop heavily when you pull a plug wire then the issue is a broader problem, possibly ignition system problem. Not enough diagnostics have been performed to give a good direction.
 

·
Administrator
1994 Firebird Formula 381ci LT1 / TH400+GV O/D
Joined
·
14,403 Posts
Have you scanned it for codes?

Has the engine been modified in any way?

Does the fuel pressure read 41 psi with or without the vacuum compensation line attached?

Have you checked all 8 spark plugs and plug wires? Have you checked the distributor cap for cracks or corroded terminals?

How old is the O2 sensor?
 
1 - 3 of 3 Posts
Top