Firebird Nation banner
1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hello everyone! I have been posting here quite a bit recently about fuel issues on my 1998 V6 Firebird. I got the fuel problems taken care of and the car runs great (for now). However when I got it back from a drive, I noticed that when I went to lock my car, the horns did not sound. They always "beep-beep" when the car is locked. I decided to press the horn on the steering wheel from inside the car, nothing. I can hear the horn relay clicking from the junction box in the engine bay.

I turned my headlights on, headlights rose up like normal and my low beams came on. I flipped the fog light switch on, and no fog lights. These both seem to ground at G105 (top right on the radiator support), but it appears that the ground is good; as my headlights and turn signals are working.

Interestingly enough, if I leave my fog light switch on, turn off my headlights so they go down... and then lock the car... my fog lights will flash. Still no horn will come on though. I was doing some work with my junction box (just cleaning all of the connections) when I was working out my fuel pump electrical problems. But everything else in the junction box is working (all relays and fuses are working fine) it's ONLY the horn and the fog lights. I swapped out the relays with a new one I had lying around, both still did not work with that new relay.

Anyone have any suggestions?
 

·
Administrator
Joined
·
3,390 Posts
For the horns, I suggest checking the fuses.could be a wiring problem between horn relay & horns. Or the relay points, which are clicking closed, have no power at the points.

For the fog lights I suspect a body control module problem. There are schematics & troubleshooting help in 98 service manual.
 

·
Administrator
1994 Firebird Formula 381ci LT1 / TH400+GV O/D
Joined
·
14,577 Posts
The ground may exist at G105 (and G106 for one fog light), but did you check for corrosion on the wire terminals?

The horn circuit and the right fog light also share Splice S112.

Does the fog light relay click when you flip the switch?

The fog lights do not appear to connect to the BCM. But the horn has a connection to the BCM so the security system can sound the horn.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
Thanks for the replies. I am going to reinspect G105 and G106. I see what you guys are saying, I see now in the manual that each fog light has a separate ground (the grounds on the sides of the radiator support). I did not listen to see if the fog light relay clicks when I press the switch, I'll have my wife sit in the car and do it while I listen.

Okay that gives me some places to look at. Both horn and fog lamps were working before I did some fuel pump work. I was messing around in the junction box area cleaning contacts (like the big power wire that goes to this particular junction box). Fuses are all fine so thats good. It is strange that my fog lights will come on when I use my keyless entry. But not when I go to turn my lights on at my headlamp switch. So they are definitely "working" right? lol. Very strange.

I do see they share splice S112. I'm really hoping I don't have a broken wire somewhere in there. Looks like I have some work to do, I will update if I find out what's going on.

Thanks you guys!
 
1 - 4 of 4 Posts
Top