Firebird Nation banner
1 - 10 of 10 Posts

·
Administrator
Joined
·
3,413 Posts
Discussion Starter · #1 ·
On my 95 trans am, the fuel pump went out on it. I let car sit for 3 months before changing the pump. Now engine will only run when gas is sprayed into intake.

My fuel injectors are not opening. I checked the 50 hertz fuel enable signal with a scope. It is fine. Security light cycles on then off as it should when key turned on.

All injectors have battery voltage on pink wires, with key on. All injector grounds have continuity and 0 resistance from pcm to injectors.

Pcm power wires all have battery voltage, both live and ignition on feeds.

All pcm grounds are good also. As well as grounds in engine compartment. All power wires from battery good also.

Have tried a known good pcm with no change.

There are no codes coming up and data scan while cranking shows pcm giving inj pulse width.

Cts is showing correct coolant temp.

Fuel pressure is up to spec when I do key on prime. All injectors spay if I supply the ground.

Cleaned out gas tank and put new gas with stabilizer added, when I changed fuel pump.

So, what am my Missing? My injectors will not open and let engine run.
 

·
Administrator
Joined
·
15,115 Posts
DTC 41 and 42 shut down the injectors. FM description appears to indicate these codes can set when the engine is cranking, e.g. DTC 41 - white wire volts exceed 4.6; DTC 42 - 84 crank revs without any IC activity.

Would seem to be worth checking the ICM and supporting wiring/circuits.
 

·
Administrator
Joined
·
3,413 Posts
But wouldn't the icm code keep ignition from functioning? As stated engine will run all day if gas sprayed into intake.

And if DTC 41 or 42 sets, I should be able to scan and get the code or codes. No codes come up on any scan that I've done.
 

·
Ramblin' Wreck
Joined
·
5,084 Posts
When you say that the "fuel injectors are not opening", does that mean you have checked with a sole'noid light and it does not flash?
 

·
Administrator
Joined
·
15,115 Posts
Then I guess I'm just dead wrong.
 

·
Administrator
Joined
·
3,413 Posts
Discussion Starter · #7 ·
Still hoping someone will have the answer. Steveo at my other forum suggested deleting vats from pcm. Used tunercat today to delete vats with no change. Fuel injectors will still not open.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top