Firebird Nation banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
83 305 "H" engine, 47,000 miles . Starts great and runs strong on cold startup. When choke opens stalling and low ( or high) idle problems. Poor performance and stumbling just off idle. Choke opens and works as designed but the throttle idle solonoid seems to work intermittently. one minute your 650RPM in drive (auto) and then it stumbles and stalls. Once warm it becomes very undrivable. Stalls when you come to stop. Starts at touch of key but drop it in drive and stumbles and stalls. this is a 100% stock , original car with Q-Jetcarb #17083526.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Yes, Air filter is new, jets work fine at different times. Will run strong cold, choke is working good, gets12v and runs great on fast idle cam, as it warms up choke opens fully. With engine now at running temp and you kick it off fast idle and rpm drops to 800 and still runs smooth. Drop into any gear and it stumbles and stalls. Touch the key it fires right up. The idle solenoid is suspect and works when it wants to. I suspect when cold the settings are default( computer is out of loop) but when it reaches temperature and the computer comes online its leaning out. Take it out on the highway and it will run okay at 60, 70 but feels like its holding back with lazy throttle response. after cruising in OD and coming to a stop it stalls , starts but stalls and your doing a dance to get it in drive and keep it running.
 
1 - 3 of 3 Posts
Top