Firebird Nation banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello masters of all Firebird. I'm a new owner of a 76 Firebird and am having some turning signal issues. Hazard lights work fine, brake lights and running lights too. However I replaced the turning signal flasher and new bulbs in all corners. Still can't get turning signals to work. Switched be blinker relay with turning signal relay with no luck. What should I check next? Can the hazeard signals work and the switches in the column for the signals be bad? Any guidance greatly appreciated.

Frustrated guy.
 

·
Administrator
Joined
·
3,296 Posts
If the hazard flashers are all working that eliminates the bulbs, sockets, and wiring to turn signal bulbs as a suspect. That leaves turn sig switch .

So your job is to download 76-77 body wiring diagram. Then test turn signal switch for power going in with key on. And power going out to left and right turn sigs when lever is flipped.

Turning hazard sw on , on most cars, cuts power to the turn sig sw. But I can't tell from the way the 76 is wired if this is in effect or not.

Also included is a turn sig troubleshooting section from 75 manual. This will work for your car as 76 supplement manual has no changes to system.
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Ok round two. Checked all contacts. Replaced whole assembly in column. Did not install new one but did plug into circuit. Same symptom. Hazards work but no signals. Traced 12 volts to relay and continuity to new switch mechanism.

Does the turning signal relay need to be a special relay? Talked to local auto parts and they said it required something different than the flasher relay type.

I'll try it tomorrow but I'm getting turned around on this thing.

Darren
 

·
Administrator
Joined
·
3,296 Posts
Yes, I believe hazard and turn sig flashers are different. At least they are in other cars I've worked on.

1 thing I don't understand about the wiring diagram I provided is. There's no hazard switch shown in the diagram.
 

·
Registered
Joined
·
103 Posts
May want to check your parking brake light lever down at bottom of steering column as well. Mine wasn't set properly and it was causing issue with my turn signals. After diagnosing all other issues, this was the cause in my case.

I corrected it and my turn signals work fine since.

http://www.ecklerscorvette.com/corvette-brake-light-switch-with-cruise-control-1977-1986.html

I also added an LED compatible relay as i am running LED's in all my turn signals and brake lights. So if you have any LED's, you will need to do the same.

http://www.ecklerscorvette.com/corvette-brake-light-switch-with-cruise-control-1977-1986.html
 
1 - 6 of 6 Posts
Top