Jump to content


FirebirdNation.com is the premier Pontiac Firebird forum on the internet. Supporting Members do not see the above ads.
Photo
- - - - -

Dtc 36 even after opti replacement


  • Please log in to reply
6 replies to this topic

#1 psilokatalist

psilokatalist

    Firebird Newbie

  • Full Member
  • Pip
  • 35 posts
  • Gender:Male
  • First Name:Coltin
  • City:appleton
  • State or Province:WI
  • Country:USA
  • Year: 1976
  • Make: firebird
  • Model: base
  • Engine: 5.7l
  • Transmission: th350

Posted A week ago

I know dtc36 is been gone over and over on these forums.  Heres my deal  bought a 93 lt1 trans am 74k miles good condition but after 20 mins starts to act up and set dtc 36.  Replaced with msd opti new plugs and wires did not fix it.  Had it sent back and tried a second one.  Still no go.  replaced the icm.  new coil.  ecm sent in to get check it passed. So next step would be to check the wires and connectors.  replaced connectors.  when i move the opti harness it seems to level the idle out and run good in the right spot.  checked all the connections with dvom didnt notice any thing weird.im going to borrow a osciliscope try to figure it out.  if anyone has any other suggestions let me know ill try it.



#2 Injuneer

Injuneer

    Just Trying to Help

  • Administrator
  • 12,253 posts
  • Gender:Male
  • First Name:Fred
  • City:East Brunswick
  • State or Province:NJ
  • Country:USA
  • Interests:Card carrying member - NHRA and AARP!

    Licensed Professional Engineer (Mechanical)
  • Year: 1994
  • Make: Pontiac
  • Model: Firebird Formula
  • Engine: 381ci LT1 stroker
  • Transmission: TH400 + GV O/D

Posted A week ago

MSD Opti has a major problem with erratic pulse signals. I've detected 5 cases now. Last one, the owner was having a problem and had an MSD Opti. He replaced the MSD with another one, problem still there. Both Gary and I independently looked at the Scan9495 data log and saw the erratic pulse signals from the optical problem.

I've sent two of these data logs to MSD Engineering, through one of their tech support people I ran across on another site. Owner sent the MSD to Engineering so they could examine it. They supposedly repaired it and returned it to the owner. Trying to get in touch with MSD, in view of the effort I put into supplying them with the data log, and my detailed analysis. So far no response.

Bottom line - I would strongly recommend avoiding an MSD Opti at all costs, until they are more forthcoming in their response.

I see from your other post you are having problems getting Scan9495 to work. Keep trying. You won't get the level of detail you need from a Snap On.

In the meantime, provide a bit more detail on what it does when it "act(s) up". Examine the routing of the Opti harness and make sure you don't have a high voltage ignition wire running close to or in parallel with it. I'm assuming since you have identified the harness as eaffecting the problem, that you have examined the connector for corrosion, damaged pins or damaged insulation.

1994 FIREBIRD FORMULA

FRED

381ci all-forged stroker - 10.8:1 - CNC LT4 heads/intake - CC solid roller - MoTeC M48 Pro engine management - 8 LS1 coils - 58mm TB - 74# injectors - 300-shot dry nitrous - TH400 - Gear Vendors 0.78:1 O/D - Strange 12-bolt - 4.11's - AS&M headers - duals - Corbeau seat - AutoMeter gauges - roll bar - Spohn suspension - QA1 shocks - a few other odds 'n ends. 800HP/800lb-ft at the flywheel, on a 300-shot. 11.5 @ 117MPH straight motor

 

gallery_709_698_32777.jpg


#3 sea dog

sea dog

    Firebird Master Tech.

  • Full Member
  • PipPipPipPipPipPipPip
  • 1,784 posts
  • Gender:Male
  • First Name:Robert
  • City:Fruitland Park
  • State or Province:FL
  • Country:USA
  • Interests:cars, guitars, women, firearms,
  • Year: 1995
  • Make: Pontiac
  • Model: transam
  • Engine: 5.7 lt1
  • Transmission: 4l60e

Posted A week ago

On the scan9495 program, did you install Microsoft dot net framework version 4.0 or newer on your computer. Scan9495 needs this to run.  If you didn't, you can download it at the site you got scan9495 from. Or go to Microsoft site.



#4 psilokatalist

psilokatalist

    Firebird Newbie

  • Full Member
  • Pip
  • 35 posts
  • Gender:Male
  • First Name:Coltin
  • City:appleton
  • State or Province:WI
  • Country:USA
  • Year: 1976
  • Make: firebird
  • Model: base
  • Engine: 5.7l
  • Transmission: th350

Posted A week ago

Ya I replaced the terminals at the harness side its all new. By act up I mean it has big misses sometimes after it misses it will start to idle almost 2000rpm. On the snap on scanner it has a signal for low resolution pulse in ms when watching it as it acts up the pulse jumps to a lower number like its getting false signals not just dropping them. Rpm on scanner jumps from like 2 anywhere up to 4-5k. I would think a broken wire bad connection would do the oposite
I downloaded the .net framework along with the program it said I already have a newer version.
I downloaded the .net framework along with the program it said I already have a newer version.

#5 psilokatalist

psilokatalist

    Firebird Newbie

  • Full Member
  • Pip
  • 35 posts
  • Gender:Male
  • First Name:Coltin
  • City:appleton
  • State or Province:WI
  • Country:USA
  • Year: 1976
  • Make: firebird
  • Model: base
  • Engine: 5.7l
  • Transmission: th350

Posted A week ago

Is it possible for the IAC or tps to be causing interference

#6 Injuneer

Injuneer

    Just Trying to Help

  • Administrator
  • 12,253 posts
  • Gender:Male
  • First Name:Fred
  • City:East Brunswick
  • State or Province:NJ
  • Country:USA
  • Interests:Card carrying member - NHRA and AARP!

    Licensed Professional Engineer (Mechanical)
  • Year: 1994
  • Make: Pontiac
  • Model: Firebird Formula
  • Engine: 381ci LT1 stroker
  • Transmission: TH400 + GV O/D

Posted A week ago

You have already found the symptoms of a faulty MSD Opti. Since I had no way to know about that data, I offered other possibilities, like wiring problems. I realize that suggestion would not be consistent with the data you found, but the only info you provided was "act(s) up". Sorry, but given your input, that was the best I could offer. Hopefully someone else can give you better help.

#7 psilokatalist

psilokatalist

    Firebird Newbie

  • Full Member
  • Pip
  • 35 posts
  • Gender:Male
  • First Name:Coltin
  • City:appleton
  • State or Province:WI
  • Country:USA
  • Year: 1976
  • Make: firebird
  • Model: base
  • Engine: 5.7l
  • Transmission: th350

Posted A week ago

Wish I had some data for ya best I can do ATM is take a video of snap on scanner but I could just tell at steady throttle cruising 2k rpms low res signal pulse goes from like 8 to 4 randomly in milliseconds. That a false signal right? Some sorta interference not a break in signal?
Wish I had some data for ya best I can do ATM is take a video of snap on scanner but I could just tell at steady throttle cruising 2k rpms low res signal pulse goes from like 8 to 4 randomly in milliseconds. That a false signal right? Some sorta interference not a break in signal?




1 user(s) are reading this topic

1 members, 0 guests, 0 anonymous users


    reay57